cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lundquist>
Subject Re: v2 (was Re: [CForms binding] access to model data from repeater row widget)
Date Wed, 22 Jun 2005 23:16:58 GMT

On Jun 21, 2005, at 8:41 AM, Mark Lundquist wrote:

> On Jun 20, 2005, at 11:42 PM, Sylvain Wallez wrote:
>> BTW, why do you prefer v2 rather than v1?
> <..schnip!..>

One thing I don't care so much for in v2 is the idiom of attaching view 
data as properties of the widget tree root.  The minimalist approach 
(losing 'bizData') was clever, but in actual practice I find that I 
really like having one locus of transfer of data between the flowscript 
and the presentation, so I usually end up with something like this 

	w.viewData =
			schtuff:	 foobar,
			etc:		otherStuff
	form.showForm ('whatev');

...and so I guess I'd rather have it as an explicit parameter (and also 
not needing to have 'viewData.' at the head of the expression path 
within the JX template).

While on the subject... since I am "Mr. Anal Nomenclature Pants", I 
would vote for changing 'bizData' to 'viewData' (as in v3)... a much 
better name IMHO :-)


View raw message