cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Ezkovich <gez...@cox.net>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 18:44:23 GMT

On Jun 14, 2005, at 12:46 PM, Sylvain Wallez wrote:

> Vadim Gritsenko wrote:
>
>
>> Ralph Goers wrote:
>>
>>
>>> Sylvain Wallez wrote:
>>>
>>>
>>>> So I propose the following:
>>>> - getId() --> getName()
>>>> - getRequestParameterName() --> getFullId()
>>>>
>>>
>>>
>>>
>>> I'm not familiar with this stuff at all, but from your  
>>> description it appears that getFullName() would be better.  You  
>>> could also use getLocalName() instead of getName(), but I like  
>>> getName() as its shorter.
>>>
>>
>>
>> I don't like getFullId too. Here are two other options:
>>
>>   - getId() --> getName()
>>   - getRequestParameterName() --> getCanonicalName()
>>
>> Or:
>>
>>   - getId() --> getLocalName()
>>   - getRequestParameterName() --> getName()
>>
>>
>> Both are names, but one is "local" and another is "global" (or  
>> "canonical").
>>
>
>
> I see your point. However, this "fullId" name is part of a two-step  
> renaming strategy, where getRequestParameterName() will end being  
> renamed getId(), an therefore getId() will have its current meaning  
> changed.
>
> The first step is:
> - rename getRequestParameterName() to getFullId()
> - rename getId() to getName()
>
> The second step, once we consider that the migration above has been  
> achieved is to deprecate getFullId() in favor of getId() with its  
> new meaning.
>
> So "fullId" should be considered as an interim name on the way to  
> "id".

As I understand it CForms is unstable. Why not just change the name  
and meaning now. I understand the desire for back compatibility but  
everyone has been warned. What you are proposing will require two  
changes to stay current.




Glen Ezkovich
HardBop Consulting
glen at hard-bop.com



A Proverb for Paranoids:
"If they can get you asking the wrong questions, they don't have to  
worry about answers."
- Thomas Pynchon Gravity's Rainbow


Mime
View raw message