cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 22:47:50 GMT
Sylvain Wallez wrote:

> A problem though: these names are good for methods, but what about 
> attributes?
> <fd:field localName="bar"> leading to a <fi:field fullName="">?
> Hmm... doesn't look that good...
> Sylvain

Very true. A name attribute on both would look better, but then you'd 
need to be able to distinguish them.  This all seems kind of arbitrary 
and forced.  I mean, it would be better if it was
<fd:field name="bar"> and <fi:field name="foo">

with getName() and getParent().getName(). getFullName() would then 
return getName() + "." + getParent().getName().

but since apparently that can't be done I would settle on
<fd:field name="bar"> and <fi:field fullName="">
and getName() and getFullName().

View raw message