cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 21:55:04 GMT
Sylvain Wallez wrote:

> Ralph Goers wrote:

>> I can see you're set on doing it this way say I'm not sure why I'm 
>> posting.  Well, yes I am....
>> It would probably be easier for everyone if getId() just went away 
>> never to be seen again.  Just pick some other name that doesn't 
>> conflict.  That is why I suggested getLocalName() and getFullName().  
>> Or whatever.
> Hmm... localName and fullName have no ambiguity that id and name may 
> have, and aren't that long enough to type. And don't require that 
> two-steps approach. Lots of advantages...
> I'll sleep on this, but I think I finally like fullName and localName :-)

A problem though: these names are good for methods, but what about 

<fd:field localName="bar"> leading to a <fi:field fullName="">?

Hmm... doesn't look that good...


Sylvain Wallez                        Anyware Technologies  
Apache Software Foundation Member     Research & Technology Director

View raw message