cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 19:17:23 GMT
Glen Ezkovich wrote:

> On Jun 14, 2005, at 12:46 PM, Sylvain Wallez wrote:

>> I see your point. However, this "fullId" name is part of a two-step  
>> renaming strategy, where getRequestParameterName() will end being  
>> renamed getId(), an therefore getId() will have its current meaning  
>> changed.
>> The first step is:
>> - rename getRequestParameterName() to getFullId()
>> - rename getId() to getName()
>> The second step, once we consider that the migration above has been  
>> achieved is to deprecate getFullId() in favor of getId() with its  
>> new meaning.
>> So "fullId" should be considered as an interim name on the way to  "id".
> As I understand it CForms is unstable. Why not just change the name  
> and meaning now. I understand the desire for back compatibility but  
> everyone has been warned. What you are proposing will require two  
> changes to stay current.

Yes, changes are possible, and each time some have occured we have made 
sure that existing code will either run in compatibility mode (with the 
appropriate deprectation logs) or fail hard by explaining what's happening.

The problem here is that the semantics of an existing method changes, 
and existing code will still compile and run, but with the wrong data. 
Hence these two steps.


Sylvain Wallez                        Anyware Technologies  
Apache Software Foundation Member     Research & Technology Director

View raw message