cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylv...@apache.org>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 17:46:06 GMT
Vadim Gritsenko wrote:

> Ralph Goers wrote:
>
>> Sylvain Wallez wrote:
>>
>>> So I propose the following:
>>> - getId() --> getName()
>>> - getRequestParameterName() --> getFullId()
>>
>>
>>
>> I'm not familiar with this stuff at all, but from your description it 
>> appears that getFullName() would be better.  You could also use 
>> getLocalName() instead of getName(), but I like getName() as its 
>> shorter.
>
>
> I don't like getFullId too. Here are two other options:
>
>   - getId() --> getName()
>   - getRequestParameterName() --> getCanonicalName()
>
> Or:
>
>   - getId() --> getLocalName()
>   - getRequestParameterName() --> getName()
>
>
> Both are names, but one is "local" and another is "global" (or 
> "canonical").


I see your point. However, this "fullId" name is part of a two-step 
renaming strategy, where getRequestParameterName() will end being 
renamed getId(), an therefore getId() will have its current meaning changed.

The first step is:
- rename getRequestParameterName() to getFullId()
- rename getId() to getName()

The second step, once we consider that the migration above has been 
achieved is to deprecate getFullId() in favor of getId() with its new 
meaning.

So "fullId" should be considered as an interim name on the way to "id".

Also, a purpose of this renaming along with some clarification is to 
save keystroke in templates, and "canonicalName" isn't much better than 
"requestParameterName" :-)

Sylvain

-- 
Sylvain Wallez                        Anyware Technologies
http://apache.org/~sylvain            http://anyware-tech.com
Apache Software Foundation Member     Research & Technology Director


Mime
View raw message