cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <va...@reverycodes.com>
Subject Re: CForms: some renamings on the Widget interface
Date Tue, 14 Jun 2005 13:28:42 GMT
Ralph Goers wrote:
> Sylvain Wallez wrote:
> 
>> So I propose the following:
>> - getId() --> getName()
>> - getRequestParameterName() --> getFullId()
> 
> 
> I'm not familiar with this stuff at all, but from your description it 
> appears that getFullName() would be better.  You could also use 
> getLocalName() instead of getName(), but I like getName() as its shorter.

I don't like getFullId too. Here are two other options:

   - getId() --> getName()
   - getRequestParameterName() --> getCanonicalName()

Or:

   - getId() --> getLocalName()
   - getRequestParameterName() --> getName()


Both are names, but one is "local" and another is "global" (or "canonical").

Vadim

Mime
View raw message