cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <>
Subject [RT] Cocoonlet
Date Wed, 27 Apr 2005 14:41:27 GMT
Our current (controversial ;) ) plan is to consider the sitemap and the 
component aspect of the original block proposal as separate concerns and 
(at least initially) solve them separately. So we will have "component 
blocks" and sitemap blocks". IMO we need a better terminology. In a 
previous mail 
( I 
called the component aspect "bundle" and the sitemap aspect "block". But 
it is not that easy to guess what is what from the name.

Having thought a little bit more about it I think it would be more 
natural to use "block" for the component aspect. It would be closer to 
our current de facto terminology. A block in Cocoon of today is 
basically a number of components that work together and are packaged 
together. It is also consistent with the Avalon terminology and the one 
from Pier's kernel.

Then we need a name for "sitemap blocks". I propose to call them 
"cocoonlets". They provide a light weight version of the Cocoon 
functionality and are supposed to work together within the Cocoon. So 
the name give some hint about what it does. One could also talk about a 
"Cocoon service" but that is more clumsy.

Of course, we have a lot invested in the brand "block". So this question 
requires carefull consideration. But I don't think the names "component 
block" and "sitemap block" are any good. They are clumsy and will 
confuse people.



View raw message