cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neeraj.J...@digitalsteps.com
Subject JSPReader Configuration for Websphere 5.1
Date Wed, 30 Mar 2005 16:24:10 GMT
Hi,

I am facing problem in configuring JSPReadre on Websphere 5.1.

I am trying to configure JSPEngine on WebSphere 5.1 required for JSPReader 
and JSPGenerator configuration.

If I use org.apache.cocoon.components.jsp.JSPEngineImpl as  jsp-engine on 
WebSphere 5.1 then I get following Exception

Exception JSPReader.generate()
org.apache.cocoon.ProcessingException: Exception JSPReader.generate(): 
java.lang.ClassCastException: com.ibm.ws.classloader.CompoundClassLoader
cause: java.lang.ClassCastException: 
com.ibm.ws.classloader.CompoundClassLoader

And If I use 
org.apache.cocoon.components.jsp.JSPEngineImplNamedDispatcherInclude as 
jsp-engine then I get following exception:

An Error Occurred
Exception JSPReader.generate()
org.apache.cocoon.ProcessingException: Exception JSPReader.generate(): 
java.lang.Exception: No RequestDispatcher found. Specify a correct 
'servlet-name': *.jsp
cause: java.lang.Exception: No RequestDispatcher found. Specify a correct 
'servlet-name': *.jsp


If any of you configured JSP Reader or JSPGenerator on WebSphere 5.1 or 
have any idea how to do it then please help me.

Thanks in Advance.
Regards,
Neeraj

Mime
View raw message