cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: Java 1.3 issue in portal block.
Date Wed, 09 Mar 2005 22:35:05 GMT
Thanks Vadim. Doing the change now in 2.1.7-dev. It will stay as is in 2.2
trunk => the minimal Java for 2.2 is 1.4

Best Regards,

Antonio Gallardo.

On Mie, 9 de Marzo de 2005, 16:30, Vadim Gritsenko dijo:
> Antonio Gallardo wrote:
>> Hi:
>>
>> Please check this code it does not compile in java 1.3:
>>
>> /home/agallardo/svn/cocoon-2.1/src/blocks/portal/java/org/apache/cocoon/portal/tools/service/UserrightsService.java:124:
>> cannot resolve symbol
>> symbol  : constructor RuntimeException  (java.io.IOException)
>> location: class java.lang.RuntimeException
>>             throw new RuntimeException(e);
>>                   ^
>
> Use CascadingRuntimeException instead.
>
>
>> Please to portal gurus to review why we need here the "new". In my view
>> this is not needed, but please confirm I can remove the "new".
>
> They want to wrap IOException into RuntimeException.
>
> Vadim
>


Mime
View raw message