cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylv...@apache.org>
Subject Re: [2.1.7-dev] o.a.c.util.Deprecation error on java 1.3.1_15
Date Mon, 14 Mar 2005 18:04:33 GMT
Antonio Gallardo wrote:

>Hi:
>
>After "svn up", I compiled the 2.1.7-dev sucessfully using 1.3.1_15, but
>it does not run [see stacktrace on the screen below]. The code compiles
>and run OK in java 1.4.2_07.
>
>************************************************************************
>
>org.mortbay.util.MultiException[java.lang.NullPointerException]
>        at org.mortbay.http.HttpServer.start(HttpServer.java:640)
>        at org.mortbay.jetty.Server.main(Server.java:429)
>        at java.lang.reflect.Method.invoke(Native Method)
>        at Loader.invokeMain(Unknown Source)
>        at Loader.run(Unknown Source)
>        at Loader.main(Unknown Source)
>[0]=java.lang.NullPointerException
>        at
>org.apache.cocoon.util.Deprecation$LoggerWrapper.setForbiddenLevel(Deprecation.java:128)
>        at
>org.apache.cocoon.util.Deprecation.setForbiddenLevel(Deprecation.java:102)
>  
>

Uh? This exception means that Enum.getEnum() doesn't behave the same on 
JDK 1.3 and JDK 1.4 ???

Anyway, I committed an update to handle the case when LogLevel is null, 
which resets to the default level, ERROR.

Sylvain

-- 
Sylvain Wallez                        Anyware Technologies
http://apache.org/~sylvain            http://anyware-tech.com
Apache Software Foundation Member     Research & Technology Director


Mime
View raw message