cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Accessors (was Re: Adding cocoon.suicide() to the FOM API.)
Date Fri, 11 Mar 2005 16:34:35 GMT
Daniel Fagerstrom wrote:

> Sylvain Wallez wrote:
>> Daniel Fagerstrom wrote: 
> <snip/>
>>> BTW, concerning what to call the "object accessors", what about just 
>>> "accessor", e.g. RequestAccessor, SessionAccessor etc.
>> "RequestObjectAccessor" or "SessionObjectAccessor" really would be 
>> too verbose, but "ObjectAccessor" for the general interface is maybe 
>> less abstract than simply "Accessor".
> Its also ok.
>> Now talking about abstraction, it will be more difficult to write 
>> something more abstract than an interface having a single "Object 
>> get()" method ;-) 
> The Component marker interface was a little bit more abstract ;)

Oh yes, forgot about that one ;-)

>> Well...
> I can agree that it seem to break some common ideas about good coding 
> practice. But we have been through the arguments and it seem OK. We 
> probably find out if it works when we start to implement and integrate it.

Oh yes, sure. I totally agree with the concept. It's not a factory and 
it's not an object holder as depending on the implementation it can be 
either or even something else. So accessor is fine!


Sylvain Wallez                                  Anyware Technologies 
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }

View raw message