cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <>
Subject Re: Adding cocoon.suicide() to the FOM API.
Date Fri, 11 Mar 2005 15:56:41 GMT
Sylvain Wallez wrote:

> Daniel Fagerstrom wrote: 


>> BTW, concerning what to call the "object accessors", what about just 
>> "accessor", e.g. RequestAccessor, SessionAccessor etc.
> "RequestObjectAccessor" or "SessionObjectAccessor" really would be too 
> verbose, but "ObjectAccessor" for the general interface is maybe less 
> abstract than simply "Accessor".

Its also ok.

> Now talking about abstraction, it will be more difficult to write 
> something more abstract than an interface having a single "Object 
> get()" method ;-) 

The Component marker interface was a little bit more abstract ;)

> Well...

I can agree that it seem to break some common ideas about good coding 
practice. But we have been through the arguments and it seem OK. We 
probably find out if it works when we start to implement and integrate it.


View raw message