cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: [GUMP@brutus]: Project cocoon (in module cocoon) failed
Date Wed, 09 Mar 2005 15:19:11 GMT
> 
> Sure,
> 
>      <work nested="build/cocoon-@@DATE@@/mocks"/>
> 
> but I don't think we should, really, in gump we already have the real 
> classes anyway... what I don't understand is what happened to the DOM 
> classes in gump in the first place!
> 
> anyway, I just added
> 
>       <depend project="xml-apis"/>
> 
> let's see if that solves the problem.
> 
I guess it does not :) I added these classes/mocks yesterday. The mocks
are required for building Cocoon with JDK 5.0 - it seems that people
wihtout any OO knowledge are defining core apis: so, from 1.4 to 5.0 the
org.w3c.dom interfaces have changed. As we implement some of them, we
know have to implement all those extra methods added to 5.0 as well.
Unfortunately not only new methods but new classes have been added as
well, so that's the reason for the mocks. If you compile with 5.0, you
don't need them.

Carsten

-- 
Carsten Ziegeler - Open Source Group, S&N AG
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message