cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Remove of the old compiling classloader implementation - Problems with WebServiceLoader
Date Tue, 15 Feb 2005 17:08:51 GMT
Reinhard Poetz wrote:
> reinhard@apache.org wrote:
> 
>> Author: reinhard
>> Date: Tue Feb 15 07:33:52 2005
>> New Revision: 153938
>>
>> URL: http://svn.apache.org/viewcvs?view=rev&rev=153938
>> Log:
>> remove Chris' javac which was replaced by new implementation of 
>> Torsten and AFAIK wasn't working; add an id to each library (first 
>> step towards a BlockBuilder)
>>
>> Removed:
>>     cocoon/trunk/lib/core/javacApi-0.9.jar
>>     cocoon/trunk/lib/core/javacImpl-0.9.jar
>>     
>> cocoon/trunk/src/java/org/apache/cocoon/components/flow/javascript/fom/CompilingClassLoader.java

>>
> 
> 
> 
> AFAIK the CompilingClassLoader hasn't worked for a long time and has 
> been replaced by Torsten's a newer implementation.
> 
> What shall we do with 2.1? Deprecate it?
> Does anybody know whether it works in 2.1 at all?


Unfortunatly the old compiling classloader implementation is used in 
org/apache/cocoon/components/flow/ws/WebServiceLoader.java. I commented out its 
use there.
Torsten will have a look at what has to be done.

Anyway, I don't think we should release 2.2 with javac-api and javac-impl 
because the legal problems of using them haven't been resolved completly (IIRC).

Sorry for the inconveniences :-(

-- 
Reinhard Pötz           Independant Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message