cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <va...@reverycodes.com>
Subject Re: FOM & FAPI (wasRe: FOM & input modules)
Date Wed, 26 Jan 2005 13:57:54 GMT
Sylvain Wallez wrote:
> Torsten Curdt wrote:
> 
>>> So I think we should clearly separate the FOM (the JS wrapper of the 
>>> OM) from the FAPI, the flowscript API which gathers 
>>> flowscript-related utility functions by attaching them for a new 
>>> "flowscript" object.
>>>
>>> We would therefore have:
>>> - cocoon.request, cocoon.context, cocoon.mymodule, etc.
>>> - flowscript.sendPageAndWait(), flowscript.getComponent(), 
>>> flowscript.redirect(), etc.
>>
>>
>> sounds good to me ...one tiny thing though: I'd prefer the name "flow" 
>> ...so
>>
>>  flow.sendPageAndWait(),
>>  flow.getComponent(),
>>  flow.redirect()

Why not cocoon.flow....? Do we really need another entry-point?


>> With javaflow the whole "script" naming scheme does not really fit 
>> ...even if you get a script-like behaviour with the compiling 
>> classloader ...IMO
> 
> 
> You're falling in the same trap again ;-)
> 
> Why should the flowscript API and javaflow API be the same?

As Torsten already said, they should be (if not the same but) close, and +1 to that.

Vadim

Mime
View raw message