cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <>
Subject Re: FOM & FAPI (wasRe: FOM & input modules)
Date Wed, 26 Jan 2005 09:48:45 GMT
>>  flow.sendPageAndWait(),
>>  flow.getComponent(),
>>  flow.redirect()
>> With javaflow the whole "script" naming scheme does not really fit 
>> ...even if you get a script-like behaviour with the compiling 
>> classloader ...IMO
>> WDYT?
> You're falling in the same trap again ;-)
> Why should the flowscript API and javaflow API be the same? In javaflow, 
> you have access to Avalon-related data such as the service manager and 
> therefore don't need flow{script}.getComponent().

Well, ok... the getComponent() will not be necessary
(that was stupid ..I should have removed that line)
...but I am not proposing the same API - just the
same naming scheme where possible.

IMHO for the user it would be nice to see that the
methodnames in flowscript and javaflow are very similiar.
...although the APIs can be different I would like to
see the API being as close as possible.


View raw message