cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <tcu...@apache.org>
Subject Re: FOM & FAPI (wasRe: FOM & input modules)
Date Wed, 26 Jan 2005 08:38:15 GMT
> So I think we should clearly separate the FOM (the JS wrapper of the OM) 
> from the FAPI, the flowscript API which gathers flowscript-related 
> utility functions by attaching them for a new "flowscript" object.
> 
> We would therefore have:
> - cocoon.request, cocoon.context, cocoon.mymodule, etc.
> - flowscript.sendPageAndWait(), flowscript.getComponent(), 
> flowscript.redirect(), etc.

sounds good to me ...one tiny thing though:
I'd prefer the name "flow" ...so

  flow.sendPageAndWait(),
  flow.getComponent(),
  flow.redirect()

With javaflow the whole "script" naming scheme does not
really fit ...even if you get a script-like behaviour
with the compiling classloader ...IMO

WDYT?

cheers
--
Torsten

Mime
View raw message