cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <>
Subject Re: [Proposal] review of sitemap component documentation
Date Sat, 04 Dec 2004 01:32:16 GMT
Bertrand Delacretaz wrote:
> David Crossley a écrit :
>> ...That is why i was asking if anyone was going
>> to say: stop, we need to throw away or redesign that
>> excellent SitemapTask to cope with separate bloack docs....
> <nitpicking>
> Just one small thing: the name SitemapTask says little about what this 
> does, as I understand you're working on it, it might be good to rename 
> it to something more meaningful. SitemapComponentDocTask maybe.
> </nitpicking>

This task has dual purposes.

1) Generate component documentation.
2) Add sitemap entries during the build process.

The tools/targets/webapp-build.xml has this
commented-out and so does tools/src/blocks-build.xsl
So perhaps it is not used for purpose #2 anymore.
If so, then yes, we should rename it as you suggest.


View raw message