cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph Goers" <Ralph.Go...@dslextreme.com>
Subject Re: JDK 1.3 build fails
Date Tue, 09 Nov 2004 22:39:50 GMT
I'm not seeing the problems you are.  My startup is just hanging. The last
message I see says the scheduler started.

Guido Schreuder said:
>
> Less funny however is that although i've gotten it build, Cocoon will
> not startup properly.
> icu4j-3.0.jar seems to be build with J2SDK 1.4.2_04-b05 and this gives me
> a
>   Exception in thread "main"
> java.lang.reflect.InvocationTargetException:
> java.lang.UnsupportedClassVersionError: com/ibm/icu/text/Normalizer
> (Unsupported major.minor version 48.0)
> from Loader.main. Replacing it with icu4j_2_8.jar (created with 1.3.1)
> works, and gets Cocoon in the air.
>
> Even then i still get an exception while starting.
> - Scheduler Cocoon_$_Tue_Nov_09_20:51:09_CET_2004 started.
> java.lang.NoSuchMethodError
>         at
> org.apache.cocoon.components.thread.DefaultRunnableManager$ExecutionInfo.execute(DefaultRunnableManager.java:822)
>         at
> org.apache.cocoon.components.thread.DefaultRunnableManager.run(DefaultRunnableManager.java:485)
>         at
> EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
>         at java.lang.Thread.run(Thread.java:479)
>
> Maybe this is related to
> http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=109990566300277&w=2
>
> Guido


Mime
View raw message