cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bart Molenkamp" <b.molenk...@bizzdesign.nl>
Subject RE: i18n and CForms
Date Thu, 25 Nov 2004 14:08:44 GMT
Hi Jeremy,

I also had that problem. My guess was that is has something to do with
the I18n transformer, which gives a problem if more than one catalogue
is configured. If you have only one catalogue, and add the contents of
FormsMessages.xml to it, it should work.

Bart.

> -----Original Message-----
> From: Jeremy Quinn [mailto:jeremy@media.demon.co.uk]
> Sent: Thursday, November 25, 2004 3:08 PM
> To: dev@cocoon.apache.org
> Subject: i18n and CForms
> 
> Hi All
> 
> I am finding that the default FormsMessages that come with CForms do
> not appear to be working in 2.1.7-dev.
> 
> My default browser locale (I tried both Safari and Firefox) is
'en_US',
> so should be using
> context://samples/blocks/forms/messages/FormsMessages.xml.
> 
> This is not happening, either in my own usage or in the samples for
> CForms.
> 
> So for instance, instead of getting the message "This field is
> required." I get "general.field-required" indicating that the lookup
> failed.
> 
> Interestingly, even after I copied "FormsMessages.xml" to
> "FormsMessages_en_US.xml" and restarted Cocoon, it still did not work.
> 
> I also tried setting Firefox to say my locale was 'fr', it still did
> not work.
> 
> The i18n Samples work fine.
> 
> Any ideas anyone?
> Can anyone else reproduce this?
> 
> 
> regards Jeremy
> 
> --------------------------------------------------------
> 
>                    If email from this address is not signed
>                                  IT IS NOT FROM ME
> 
>                          Always check the label, folks !!!!!
> --------------------------------------------------------

Mime
View raw message