cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: [rant] please backport bugfixes to 2.1!
Date Tue, 02 Nov 2004 11:17:04 GMT
Carsten Ziegeler wrote:

>Sylvain Wallez wrote:
>>>There are other changes as well - internal processing etc. But the good news is:
you can use the ExtendedComponentSelector in the configuration, although the class doesn't
exist. ECM++ will automatically use the CocoonServiceSelector. This is for compatibility.
>>Mmmh... looks like a big hack. Why not simply reinstalling 
>>ExtendedComponentSelector as I suggested?
>Sorry, but I don't understand where your real problem here is.
>If you think that you can't merge the two branches because of different
>configuration files, then simply use ExtendedComponentSelector
>in 2.2 as well - it works and solves your problem.

It won't solve the problem (if it was just that, it would be easy), but 
could ease having the exact same files for many blocks in both branches.

>If you think that you need this class as well, add it.

I'll consider that after syncing the code in CForms.

>But I think, the real problem is that people forget to keep the branches
>in sync :(

Yep, this is the real problem.


Sylvain Wallez                                  Anyware Technologies 
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }

View raw message