cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <va...@reverycodes.com>
Subject Re: [Heads up] Change to build system in 2.1.x
Date Sun, 31 Oct 2004 15:59:46 GMT
Ralph Goers wrote:
> Vadim Gritsenko wrote:
> 
>> Ugo Cei wrote:
>>
>>> Looks like this is not a backward-compatible change. Blocks which are 
>>> distributed outside of Cocoon (like Fins or my Spring Petstore) must 
>>> change their deployment instructions to add all those <depend> 
>>> elements (and put dependencies in gump too, which wasn't required 
>>> before, even though it might have been good practice).
>>>
>>> Shouldn't we make this change in trunk only and leave 2.1 as is?
>>
>>
>> It was required for libs dependencies cleanup. Before, you either had 
>> to duplicate the lib, or put fake dependency between blocks. Now we 
>> can cleanup these unnecessary dependencies, and build will find 
>> required libs for the blocks.
>>
>> I say let's leave it in.
> 
> 
> I believe the policy says that these sort of changes (like deprecating 
> something) require that they be announced in one maintenance release and 
> then they can be put in the next.  So this change can only happen in 
> 2.1.7, if I have it right.

You are right - but only for actual code, not for bat files.

Vadim

Mime
View raw message