cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24741] - <util:get-sitemap-parameter/> returns nothing when used in a generator nested within an action
Date Sun, 26 Sep 2004 20:35:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=24741>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=24741

<util:get-sitemap-parameter/> returns nothing when used in a generator nested within
an action





------- Additional Comments From agallardo@agsoftware.dnsalias.com  2004-09-26 20:35 -------
This bug is quite old. What I understood from the initial report is:

The source XML used in the XSP generator called in the sitemap.xmap is
docs/category.xsp:

<map:generate type="serverpages" src="docs/category.xsp">
   <map:parameter name="admin" value="!!!"/>
</map:generate>

The docs/category.xsp, has the following snipet inside:

<xsp:logic>
 String admin=<util:get-sitemap-parameter name="admin"/>;
</xsp:logic>
<xsp:expr>admin</xsp:expr>

and the snipet retuns no value.

*************************************************
I already checked the source of the util logicsheet. And what in fact we are
calling inside the docs/category.xsp is this function:

<!-- Returns value of a sitemap parameter, null if that parameter is
     undeclared "name" attribute should be specified.
  -->
  <xsl:template match="util:get-sitemap-parameter">
    <xsp:expr>(parameters.getParameter("<xsl:value-of select="@name"/>",
null))</xsp:expr>
  </xsl:template>

Can someone else confirm if the bug is still valid in the 2.1.x branch?

Mime
View raw message