cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31134] New: - SimpleFormsTransformer does not work
Date Wed, 08 Sep 2004 22:15:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31134>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31134

SimpleFormsTransformer does not work

           Summary: SimpleFormsTransformer does not work
           Product: Cocoon 2
           Version: 2.1.5
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: core
        AssignedTo: dev@cocoon.apache.org
        ReportedBy: Ralph_Goers@dslextreme.com


In trying to upgrade from 2.1.4 to 2.1.5.1 we discovered that the
SimpleFormTransformer is now broken. Both our site and the Cocoon sample are
failing.  The symptom is that none of the initial (default) values are
displayed.  In addition, sitemap.log contains:

WARN    (2004-09-08) 14:43.31:102   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/persons': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:114   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/type': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:116   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/deposit': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:118   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/email': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:119   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/address': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:130   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/driver': Module does not
support <>attribute.
WARN    (2004-09-08) 14:43.31:136   [sitemap.transformer.simpleform-instance]
(/samples/simpleform/four/index) PoolThread-4/SimpleFormTransformer: A problem
occurred acquiring a value from 'jxpath' for '/car/car/go': Module does not
support <>attribute.

I have verified that this problem still exists in BRANCH-2.1.X.

To reproduce this simply run:
http://localhost:8888/samples/simpleform/four/index

The form should have default values but none are there. The same page with 2.1.4
displays the defaults.

Mime
View raw message