cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Zehetbauer <thom...@hostmaster.org>
Subject XSP compile failure when using JDK1.5 features
Date Tue, 31 Aug 2004 19:32:06 GMT
Hi,

I am trying to use the new JDK1.5 foreach loop in XSP, basically:

List entries = new ArrayList();
for (Map entry: entries) {
        ...
}

which causes the following error with the default EclipseJavaCompiler:

// start error (lines 1003-1003) "Syntax error on token ":", ";"
expected"
                                                for (Map entry: entries)
{

// end error

or even with the Javac compiler:

/home/tomcat/work/Default/beta.hostmaster.org/_/cocoon-
files/org/apache/cocoon/www/Dictionary_xsp.java:1003: ';' expected.
                                                for (Map entry: entries)
{

Cocoon is running under Tomcat 5.0.28 on j2sdk-1.5.0-beta2-b51. Any idea
what is causing this problem and how to fix it?

Tom
-- 
  T h o m a s   Z e h e t b a u e r   ( TZ251 )
  PGP encrypted mail preferred - KeyID 96FFCB89
      finger thomasz@hostmaster.org for key

Sacrilegia minuta puniuntur, magna in triumphis feruntur
                                      - Seneca



Mime
View raw message