cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@d-haven.org>
Subject Problem with compile defaults
Date Wed, 09 Jun 2004 16:06:29 GMT
If someone is experimenting with Java 1.5 on their system (like me), the
Java 1.5 compiler will cause a problem because you specify a target of
1.3 without specifying the source parameter.  The source parameter is
the most important aspect, and you will have a target of 1.2 if you
specify a source of 1.2 or 1.3.

Please do not use the target parameter on javac without a corresponding
source parameter.

Problematic:

javac -target 1.3 ....

This will cause problems if the default source parameter changes (as it
does from 1.4 to 1.5beta1 to 1.5beta2.

Best:

javac -source 1.3 ....

This will allow the compiler to generate the corresponding target
automatically and you don't get bitten by the default source changes.



-- 

"Programming today is a race between software engineers striving to 
build bigger and better idiot-proof programs, and the Universe trying to 
produce bigger and better idiots. So far, the Universe is winning."
                 - Rich Cook


Mime
View raw message