cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Quinn <jer...@media.demon.co.uk>
Subject Re: Serious FlowScript problem
Date Thu, 24 Jun 2004 12:49:56 GMT

On 24 Jun 2004, at 12:27, H.vanderLinden@MI.unimaas.nl wrote:

> FWIW: I've struggled with an improperly working 'context' protocol 
> myself
> somewhere. Could you change it to a hard-coded absolute path just for
> checking?

Thanks for your suggestion, but context:// has never been an issue for 
me in the past.

The point I was trying to make is that I could demonstrate that with 2 
separate references to the same script, one worked, one did not.

It does not matter whether I use context:// or a full or a relative 
path, sometimes when Cocoon starts up they both work, sometimes when 
Cocoon starts up only the Lucene Sample works.

regards Jeremy

> Bye, Helma
>
>> -----Original Message-----
>> From: Jeremy Quinn [mailto:jeremy@media.demon.co.uk]
>> Sent: Wednesday, 23 June 2004 17:08
>> To: dev@cocoon.apache.org
>> Subject: Re: Serious FlowScript problem
>>
>>
>>
>> On 23 Jun 2004, at 13:08, Jeremy Quinn wrote:
>>
>>>>> On 23 Jun 2004, at 10:58, Jeremy Quinn wrote:
>>>>>
>>>>>> I have been seeing this problem ever since I moved to 2.1.5.
>>>>>> Interestingly, I never once saw this problem while I was
>> working on
>>>>>> the Query Bean addition to Cocoon I recently added.
>>>>>>
>>
>> One of my pipelines uses the Query Bean stuff I added recently.
>>
>> I call the url:
>> 	
> 	http://localhost:8888/myprojectname/search/advanced.html
>
> and I get the usual :
>
> org.apache.cocoon.ResourceNotFoundException: Function
> "javascript:simpleLuceneQuery()" not found
>
> I immediately call the url:
>
> 	http://localhost:8888/samples/blocks/lucene/query/advanced.html
>
> Which uses exactly the same flowscript file, and it works perfectly
> !!!!!!!
> And I do not mean the same content, I mean it really uses the SAME 
> file.
>
> in the first case it is loaded like this:
> 	<map:flow language="javascript">
> 		<map:script
> src="context://samples/blocks/lucene/query/query.js"/>
> 	</map:flow>
>
> in the second case like this:
> 	<map:flow language="javascript">
> 		<map:script src="query.js"/>
> 	</map:flow>
>
> I go back to the original url and it is still broken.
>
> What is going on ??????????
>
> Can someone at least suggest a way to find out *where* it is going
> wrong?
>
> regards Jeremy
>
>
>
>
--------------------------------------------------------

                   If email from this address is not signed
                                 IT IS NOT FROM ME

                         Always check the label, folks !!!!!
--------------------------------------------------------


Mime
View raw message