cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "roy huang" <lingererhu...@hotmail.com>
Subject Re: [help]using two portals in the same time
Date Fri, 18 Jun 2004 10:24:02 GMT
I have send a mail to you,check it.

Roy Huang
----- Original Message ----- 
From: "Carsten Ziegeler" <cziegeler@s-und-n.de>
To: <dev@cocoon.apache.org>
Sent: Friday, June 18, 2004 5:45 PM
Subject: RE: [help]using two portals in the same time


> Hi,
> 
> I can't confirm it, but this might be a bug. If you could send me the
> complete
> app (or at least the relevant parts - cocoon.xconf, sitemaps etc.) I might
> be able to look into the problem. Please don't send it to the list (because
> of the mail size).
> 
> Carsten
> 
> > -----Original Message-----
> > From: roy huang [mailto:lingererhuang@hotmail.com] 
> > Sent: Thursday, June 17, 2004 3:42 PM
> > To: dev@cocoon.apache.org
> > Subject: [help]using two portals in the same time
> > 
> > Hi,all:
> >     I setup a portal basing samples working just fine.But 
> > when I setup another one in different directory something 
> > wrong happen,here's my step:
> >     1.In order to avoid authtication conflict,I rename second 
> > portal's authentication handler form "portal" to 
> > "standard-portal" in its sitemap
> >     2.Rename second portal application name from "portal" to 
> > "standard-portal"
> >     3.In cocoon.xconf,add
> >  <portal name="standard-portal">
> >    
> > <profile-manager>org.apache.cocoon.portal.profile.ProfileManag
> > er/Auth</profile-manager>
> >  </portal>
> >     below the sample portal
> > 
> >     If I access both two portal alone ,everything's fine,but 
> > if I access any one first and access the other one,the portal 
> > need to login(correct).It works wrong:
> >     After login,the portal still display the anonymous 
> > layout,and the logout link in the right top is displayed.So 
> > authtication is pass. So it must the load profile didn't work right.
> > 
> >     I'm using 2.1.5 with tomcat 4.1.30+jdk 1.4.2,I also 
> > repeat this error by copy the director of portal to standard 
> > and modify it follow the upper steps using jetty ship by 2.1.5.
> > 
> >    What I miss or is it a bug?
> > 
> > Roy Huang
> > 
> 
> 
Mime
View raw message