cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: Removing groovy
Date Thu, 17 Jun 2004 08:16:56 GMT
Antonio Gallardo wrote:

>Upayavira dijo:
>  
>
>>Antonio Gallardo wrote:
>>
>>    
>>
>>>Tony Collen dijo:
>>>
>>>
>>>      
>>>
>>>>Vadim Gritsenko wrote:
>>>>
>>>>
>>>>        
>>>>
>>>>>Hi,
>>>>>
>>>>>I'm not sure (yet) where Groovy is used - but it has to be removed from
>>>>>core Cocoon, lib/optional, into some block. Reason is simple - Cocoon
>>>>>supports JDK1.3, and Groovy - not. Either JDK1.3 support should go, or
>>>>>Groovy should go (into the block, at least).
>>>>>
>>>>>Opinions?
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>Move into its own block, mark as unstable (and possibly disabled by
>>>>default).
>>>>
>>>>Perhaps we can think of losing 1.3 support once 1.5 is finalized.
>>>>
>>>>
>>>>        
>>>>
>>>Yep. AFAIK, it was already decided for the next version.
>>>
>>>
>>>      
>>>
>>No, it was decided for 2.2, but 2.1.x will always have JDK1.3 support.
>>That is how I remember it.
>>    
>>
>
>Yep. We are now on 2.2-dev :-D
>  
>

IIRC there was no vote. We only said that if there are really good 
reasons we think about droping 1.3 support. Not more.
For now I'm -1 on this because there *are* users out there relying on 
1.3 (see the last poll on the users mailing list) and don't forget, not 
all users are subsribed to our mailing lists.

-- 
Reinhard


Mime
View raw message