cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: Removing groovy
Date Wed, 16 Jun 2004 22:28:45 GMT
Vadim Gritsenko dijo:
> Hi,
>
> I'm not sure (yet) where Groovy is used - but it has to be removed from
> core Cocoon, lib/optional, into some block. Reason is simple - Cocoon
> supports JDK1.3, and Groovy - not. Either JDK1.3 support should go, or
> Groovy should go (into the block, at least).

Currently, Groovy is used in 2 blocks: bsf and scratchpad. Our actual
build system is not smart enough to know in which block we use a jar. We
simply copy all the lib/optional/*.jar to the build. I know it is a PITA.
We have a similar problem with other jars. ie: even if you exclude XSP you
got the jdtcore and pizza included for free and they are not used at all.

I think the solution is try to define what optionals jars are needed based
on the users block selection.

BTW, I posted about this problem long time ago and seems that nobody cares
about that. I learned to delete the not needed jars after building.

> Opinions?

I have the same question as you. ;-)

Best Regards,

Antonio Gallardo


Mime
View raw message