cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From H.vanderLin...@MI.unimaas.nl
Subject Session losing authentication context - still an open bug?
Date Mon, 10 May 2004 21:08:57 GMT
Guys,

I've run into a problem that is probably a variation of an old bug. It would
be really nice if this could be solved before 2.1.5.

Problem:

My webapp has it's own sitemap in a separate directory below the standard
Cocoon sitemap in the root dir. I suppose this is a subsitemap, I just keep
forgetting to look at it this way.

I built my authentication along the lines of the Authentication-fw with flow
sample. I've tried building a flowscript function per use case. This works
until I want to move onto the next function. Then I get an error like
"authentication context not found in session". 

Could someone please solve this?

Related: I cannot go from one "protected/pipeline" to the next
"protected/pipeline2" without the above error, so I need to go to the
"public/pipeline" that goes through the "protect" function. If I do that I
loose all the bizData I added to the cocoon.sendPage("public/pipeline",
bizData) statement.

Does anybody know what to do? I now solve it by adding the objects to the
session, but there must be a more elegant way.

Thanks.

Bye, Helma

Mime
View raw message