cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fredy Dobler" <fr...@dobler.net>
Subject Re: [CForms] UTF-8, ISO-8859-1 encoding problem
Date Wed, 05 May 2004 15:34:03 GMT
> On Wed, 2004-05-05 at 15:29, Fredy Dobler wrote:
>> I'm using the latest cvs version (2.1.5-dev), the cocoon-forms block and
>> the jetty from the cocoon cvs.
>> The only thing I can't get working right is the character encoding of
>> the
>> submited parameters of a html form.
>>
>> I've set all settings I've found to utf-8 (web.xml, cocoon.xconf,
>> java.encoding, ...).
>
> But in the web.xml, have you left the container-encoding parameter to
> ISO-8859-1?
No, I've uncommented the lines.

Snippet from my web.xml:
    <!--
      Set encoding used by the container. If not set the ISO-8859-1 encoding
      will be assumed.
    -->
    <init-param>
      <param-name>container-encoding</param-name>
      <param-value>utf-8</param-value>
    </init-param>

    <!--
      Set form encoding. This will be the character set used to decode
request
      parameters. If not set the ISO-8859-1 encoding will be assumed.
    -->
    <init-param>
      <param-name>form-encoding</param-name>
      <param-value>utf-8</param-value>
    </init-param>


>
> --
> Bruno Dumon                             http://outerthought.org/
> Outerthought - Open Source, Java & XML Competence Support Center
> bruno@outerthought.org                          bruno@apache.org
>
>
>

Fredy

Mime
View raw message