cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Dumon <br...@outerthought.org>
Subject Re: [CForms] Repeater is not a ContainerWidget?
Date Thu, 06 May 2004 21:44:46 GMT
On Mon, 2004-05-03 at 18:43, Sylvain Wallez wrote:
<snip/>
> Reading also Jörg's opinion, my preferred navigation API is :
> - getChild(String name) to get a direct child of a widget (replaces 
> getWidget which isn't precise enough to say if it considers children 
> only or also descendants)
> - lookupWidget(String qname) which does a descendant lookup only, based 
> on child names sperarated by dots.

Sorry for revisiting this yet another time, but I wanted to throw in
another thought about the lookupWidget.

How about separating the child names with slashes instead of dots?

The reason: this would provide an obvious syntax for moving up in the
tree: e.g. "../widget", and "/widget" for absolute navigation.

This would, among other things, be useful in the expressions. If we
change the variable resolving there to use lookupWidget instead of
getChild, this would allow expressions to refer to any other widget in
the tree.

I don't think it is important to match the dotted notation we have in
the request parameter names, as I see that as a completely unrelated
thing. In that regard, getFullyQualifiedId() should maybe be renamed to
getRequestParameterName().

-- 
Bruno Dumon                             http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
bruno@outerthought.org                          bruno@apache.org


Mime
View raw message