cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <>
Subject Re: SVN and Certificates
Date Thu, 27 May 2004 14:52:39 GMT
I had this problem (before I gave up on Subclipse, on M7 over modem). I
think the trick is to run svn to this repository on the commandline first,
and manually accept this. Subclipse doesn't complain after that. (I think
this came up on infra@ a month or more ago, but I'm not sure if there is an
archive to help you.)

FWIIW: I now use SVN commandline outside of Eclipse. It is tolerable, most
of the time. If/when I use Eclipse to refactor and packages (directories)
get moved, the .svn sub-directories get moved around, which completely
pisses off SVN. I've tried all sorts of cleanups (including moving dir out,
svn del/svn commit/manually deleting .svn from dir/moving back/svn add/svn
commit) -- and all are painful.

The biggest problem if I just don't notice when I (and Eclipse) are doing
it/causing it, and that SVN tends to punt when confused (and no amount of
svn cleanup/svn add/svn del can cope). I got in such a mess yesterday my
'fix' was to delete the project and re-checkout. Hardly efficient.

This misery is probably partly my own (not being an SVN expert, and SVN has
yet to mature) and partly that I work over a modem (long story). I am told
things work a little better w/ latest Subclipse and M8/M9, but still not
100% reliably. I've not been lucky enough to get a download to try.


----- Original Message ----- 
From: "Pier Fumagalli" <>
To: <>
Cc: <>; <>
Sent: Thursday, May 27, 2004 8:39 AM
Subject: Re: SVN and Certificates

> On 27 May 2004, at 09:36, Reinhard Poetz wrote:
> >
> > As Cocoon will move to SVN soon, I tried to work with the latest
> > Subclipse client. Unfortunatly I always get an error:
> >
> > svn: Commit failed (details follow):
> > svn: OPTIONS request failed on '/repos/test/cz/new'
> > svn: OPTIONS of '/repos/test/cz/new': Server certificate verification
> > failed: issuer is not trusted (
> >
> >
> > Subclipse doesn't offer the possibility to accept untrusted
> > certificates like command-line SVN or TortoiseSVN does. A workaround
> > is using one of the mentioned tools and accept the certificate
> > permanently. But this can't be a final solution, IMO.
> >
> > Are there any plans to setup a valid certificate for
> Did you actually manage to get SubEclipse working???????? :-P What
> platform (keeps crashing my Eclipse M8 on MacOS/X)
> Pier

View raw message