cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <>
Subject [Vote] notation of blocks selection properties
Date Thu, 01 Apr 2004 12:39:41 GMT
> Le 31 mars 04, à 23:46, Joerg Heinicke a écrit :
> > ...WDYT? Change only the documentation (to "use true|false") or 
> > additionally the property names from exclude to include....
> I'm for changing from exclude to include, but you might want to ask for 
> a [VOTE], or at least a quick vote as this is a kind of "interface 
> change".
> -Bertrand

Ok, then let's start a vote for it:

For recall the thread can be found at, the important part
starts at

It's about changing the notation for blocks selection properties from
exclude.block.blockname to include.block.blockname, which IMO is a bit more

As I wrote in my mail, the solution I have is partly backward compatible, this
means a in the old style will still work and the blocks
selection will be as expected expected for the case
exclude.block.blockname=false is already in use. This works because I changed
the unless.exclude.block.blockname property (to which exclude.block.blockname is
mapped to) to only exclude.block.blockname.

So now the vote:

[ ] exclude.block.blockname=true|false
[ ] include.block.blockname=true|false


View raw message