cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: [portal] Bookmarks and CachingURICoplets - bug?
Date Wed, 28 Apr 2004 14:10:51 GMT
Hmmm, I think I understand you know :)

Did you try a redirect:

 <map:match pattern="subscribe">
  <map:redirect-to uri="cocoon:/bookmark?top=4"/>
</map:match> 

Carsten
> -----Original Message-----
> From: Alex Romayev [mailto:romayev@yahoo.com] 
> Sent: Wednesday, April 28, 2004 4:00 PM
> To: dev@cocoon.apache.org
> Subject: RE: [portal] Bookmarks and CachingURICoplets - bug?
> 
> Hi Carsten,
> 
> What I'm saying is that the coplet works fine, unless 
> accessed the page it's on is accessed via:
> 
> <map:match pattern="subscribe">
>   <map:generate src="cocoon:/bookmark?top=4"/>
>   <map:serialize type="html"/>
> </map:match>
> 
> In that case, the page is reloaded with
> portal?bookmark url when I click submit and the form is blank.
> 
> Am I making sense?
> 
> -Alex
> 
> --- Carsten Ziegeler <cziegeler@s-und-n.de> wrote:
> > Hi,
> > 
> > I'm not sure, if I understand your approach correctly, but 
> it might be 
> > that the CachingURICoplet serves the blank form because it 
> thinks that 
> > the coplet didn't change. Can this be your problem?
> > 
> > Carsten
> > 
> > > -----Original Message-----
> > > From: Alex Romayev [mailto:romayev@yahoo.com]
> > > Sent: Wednesday, April 28, 2004 2:57 PM
> > > To: dev@cocoon.apache.org
> > > Subject: [portal] Bookmarks and CachingURICoplets
> > - bug?
> > > 
> > > I have a CachingURICoplet, basically a CForm.  The
> > page with
> > > the coplet is accessed via a bookmark:
> > > 
> > > <map:match pattern="subscribe">
> > >   <map:generate src="cocoon:/bookmark?top=4"/>
> > >   <map:serialize type="html"/>
> > > </map:match>.
> > > 
> > > When I submit the form, I get re-directed to the
> > same page,
> > > however the url is now: portal?bookmark and the
> > form is
> > > redisplayed blank.  After filling it out the
> > second time,
> > > everything works as usual.
> > > 
> > > Is this a bug, or is there something else I need
> > to do to get
> > > CachingURICoplets to work with bookmarks?
> > > 
> > > Thanks,
> > > -Alex
> > > 
> > > 
> > 
> 
> 


Mime
View raw message