cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "roy huang" <lingererhu...@hotmail.com>
Subject Re: npe with portal block sample.
Date Wed, 28 Apr 2004 14:45:48 GMT
Hi Carsten:
    Your fix is so quick! Thanks!
    Another question ,it might not a bug ,but I think it is should still be raised.
   If you use the two same coplet in the same tab ,delete one of then will result an error
said can't find the coplet (the coplet having been delete).I believe is the same coplet but
have not been deleted result this. Should it produce a better message or just keep or both
delete the coplet?
   WDYT?

Roy Huang

----- Original Message ----- 
From: "Carsten Ziegeler" <cziegeler@s-und-n.de>
To: <dev@cocoon.apache.org>
Sent: Wednesday, April 28, 2004 7:55 PM
Subject: RE: npe with portal block sample.


> Hi,
> 
> thanks for reporting this! Yes, this is a bug. I just fixed the first
> one and committed it to the CVS, but the second one is still there :(
> Can you please file a bug, then it will not get lost.
> 
> Thanks!!
> 
> Carsten 
> 
> > -----Original Message-----
> > From: roy huang [mailto:lingererhuang@hotmail.com] 
> > Sent: Wednesday, April 28, 2004 9:58 AM
> > To: dev@cocoon.apache.org
> > Subject: npe with portal block sample.
> > 
> > Hi all.
> >   I use portal block as application main page,it always 
> > produce NPE,but I can't conclude it.Today I tried 
> > http://localhost:8888/samples/blocks/portal/portal in current 
> > cvs version and found the sample will produce NPE too.I don't 
> > know if it is a bug or has been posted in Bugzilla,so I describe here:
> >   In the sample,login as cocoon then:
> >   1.In News tab ,select one coplet,full screen,delete it.NPE appear:
> > org.apache.cocoon.ProcessingException: Failed to execute 
> > pipeline.: java.lang.RuntimeException: java.lang.NullPointerException
> > 
> > Original Exception: java.lang.RuntimeException: 
> > java.lang.NullPointerException
> > at 
> > org.apache.xalan.transformer.TransformerImpl.run(TransformerIm
> > pl.java:3418)
> > at 
> > org.apache.xalan.transformer.TransformerHandlerImpl.endDocumen
> > t(TransformerHandlerImpl.java:389)
> >  ...
> > 
> >   2.Refresh the browser,the correct window appear.
> > 
> >   3.Select TabDemo2,NPE appear again and the whole portal 
> > doesn't work then.
> > 
> > org.apache.cocoon.ProcessingException: Failed to execute 
> > pipeline.: java.lang.RuntimeException: java.lang.NullPointerException 
> > 
> > Original Exception: java.lang.RuntimeException: 
> > java.lang.NullPointerException
> > at 
> > org.apache.xalan.transformer.TransformerImpl.run(TransformerIm
> > pl.java:3418)
> > at 
> > org.apache.xalan.transformer.TransformerHandlerImpl.endDocumen
> > t(TransformerHandlerImpl.java:389)
> > at 
> > org.apache.cocoon.xml.AbstractXMLPipe.endDocument(AbstractXMLP
> > ipe.java:56)
> > 
> > ...
> > 
> > If you select TabDemo2 at the first and 
> > full-screen--->delete,it generate NPE directly and 
> > fatally.Only logout can return the login page.
> > 
> > Is it a bug and is it have been post in Bugzilla?
> > 
> > 
> > 
> > Roy Huang
> > 
> > 
> 
> 
Mime
View raw message