cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Noels <stev...@outerthought.org>
Subject Re: Cocoon 1.8 to 2.1.4 Help
Date Wed, 07 Apr 2004 09:18:37 GMT
On 07 Apr 2004, at 10:54, Yacoubou.WAOLANY@cec.eu.int wrote:

> Hi,
>
> I try to migrate webapplication (wich written in 1999 with cocoon 1.8)
>> From cocoon 2.1.4. But I can find the packages below:
>
> org.apache.cocoon.processor.*;
> org.apache.cocoon.framework.*;
> org.apache.cocoon.transformer.*;
> org.apache.cocoon.parser.*;
> org.apache.cocoon.producer
>
> Can you tell me what about them in cocoon 2.1.4 ?

There is no such thing as a simple migration path from Cocoon 1.8 to 
Cocoon 2, which uses wildly different concepts such as the sitemap and 
SAX pipelining. Cocoon 1.8 is very old, and it will be hard to find any 
support or documentation for it.

What custom 1.8 components would you like to re-code? Maybe we can give 
you some documentation pointers. 
http://wiki.cocoondev.org/Wiki.jsp?page=MigrateToCocoon2 might help you 
a bit.

Cheers,

</Steven>
-- 
Steven Noels                            http://outerthought.org/
Outerthought - Open Source Java & XML            An Orixo Member
Read my weblog at            http://blogs.cocoondev.org/stevenn/
stevenn at outerthought.org                stevenn at apache.org


Mime
View raw message