cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [woody] upload widget, unexpected behaviour
Date Thu, 08 Apr 2004 09:19:26 GMT
On 08.04.2004 11:15, Jeremy Quinn wrote:

> Hi All
> 
> I am making a woody form that allows the user to upload an image along 
> with a bunch of meta-data fields.
> 
> The meta-data fields are described normally in the model, binding and 
> template.
> 
> The upload widget is declared in the model and template, but not the 
> binding as it does not belong in the Bean being made from the meta-data.
> 
> There is an @enctype="multipart/form-data" declared on the 
> wt:form-template element in the template, for the upload widget.
> 
> The continuation was originally setup as a hidden field, with an 
> appropriate request-matcher in the sitemap.
> 
> When submitting the form, the continuation pipeline was not being called 
> so I switched to putting the continuation id in the @action of the form 
> (and changed the sitemap accordingly).
> 
> Now when I submit the form, the continuation is triggered but no form 
> values are copied into the model and back to the form.
> 
> When I remove the @enctype="multipart/form-data" form values do get 
> copied into the model, but of course the file upload would not work like 
> this.
> 
> In the upload sample that comes with woody, there is no binding at all, 
> and values are read 'by hand'.
> 
> 
> What am I missing?

Enabling uploads? I have updated the FAQ on the wiki only few minutes 
before your post: http://wiki.cocoondev.org/Wiki.jsp?page=FAQs (at the end).

Joerg

Mime
View raw message