cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Quinn <jer...@media.demon.co.uk>
Subject Re: FlowScript in 2.1.5-dev has gone tango uniform
Date Tue, 02 Mar 2004 18:42:17 GMT

On 2 Mar 2004, at 15:22, Christopher Oliver wrote:

> Can you try reverting the rhino jar to a previous version and see if 
> that fixes the problem? I may have introduced a regression.

Many thanks for your reply.

I picked up :

	rhino1.5r4-continuations-20040218.jar
   and
	rhino1.5r4-continuations-20030906.jar

from CVS and one by one replaced rhino1.5r4-continuations-20040228.jar 
with them, in build/webapps/WEB-INF/lib, it made no difference.

then I tried recompiling 2.1.5-dev with 
rhino1.5r4-continuations-20030906.jar (in lib/core, and jar.xml). The 
problem is still not fixed.

To restate the basic problem :

I have 2 URLs each served by a different sub-sitemap, each loading a 
different (single) flowscript. Each flowscript has some common function 
names, eg. index(). For debugging purposes, each function outputs it's 
name etc. to the flow log.

load URL 1 : the correct script and function run fine
load URL 2 : the same-named function in the flowscript file for URL 1 
runs.

regards Jeremy

> Jeremy Quinn wrote:
>
>> Hi All
>>
>> I just upgraded my copy of Cocoon to today's CVS version.
>>
>> A (previously working) site that uses a lot of FlowScript has gone 
>> completely TU.
>>
>> I am getting a lot of this :
>>
>> org.apache.cocoon.ResourceNotFoundException: Function 
>> "javascript:album()" not found
>>
>> Where it worked before the update.
>>
>> But stranger still, while I was doing some testing, I got an error 
>> that said that a script that was not even referred to by the current 
>> pipeline, did not contain the function I was calling !!!!!!
>>
>> Do what ?!?
>>
>> Have there been some changes to the FlowScript infrastructure that 
>> could result in the wrong FlowScript file being used under certain 
>> circumstances?
>>
>> I have several flowscripts, used independently by different 
>> Sub-SiteMaps, that have the same function names. The first SiteMap I 
>> invoke, works (does not matter which one) all subsequent invocations 
>> of pipelines with similar (but different) FlowScripts fail.
>>
>>
>> Any ideas anyone?
>>
>>
>> regards Jeremy
>
>

Mime
View raw message