cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: [VOTE] - Entry level JSDK 1.4 in Cocoon 2.2
Date Tue, 02 Mar 2004 01:22:11 GMT
Ugo Cei wrote:

> Antonio Gallardo wrote:
>
>> Do you agree with JSDK 1.4 as the lower Java version supported in 
>> Cocoon 2.2?
>>
>> Here is my +1
>
>
> -0.5
>
> Even though 1.4 is available for most platforms, and I've been using 
> it exclusively for quite a long time, I still think there are many 
> environments where people are forced to use 1.3 (not to mention 1.2) 
> and upgrading wouldn't be an easy task.


Does anyone here have any direct experience with such a situation?  I am 
having a hard time imagining a case where a new development effort would 
be forced for technical reasons not to deploy on a newer backwards 
compatible jdk.  Old 1.3 code will run (in some cases after 
recompilation), and old projects can still use whatever jvm version they 
need.  But a new project based on a new version of Cocoon?  Ok, a 2.1 
project may want to upgrade but my experiences have shown upgrading jvm 
generally painless compared to upgrading Cocoon versions...

Geoff

> If, and when, we have something that absolutely requires 1.4 (say, a 
> new caching system based on NIO, like Pier suggested), we might 
> reconsider this requirement. Doing it now would just alienate many 
> users without really buying us anything important.
>
> I suggest to repeat this vote when we have a proposed time frame for 
> the release of 2.2.
>
>     Ugo


Mime
View raw message