cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Problem: Building Cocoon with ant under Eclipse 3.0M7
Date Mon, 01 Mar 2004 20:53:08 GMT
On 01.03.2004 00:24, Antonio Gallardo wrote:

>>I was hit by that a few days ago on a different project, and it's an
>>endorsed problem, due to a wrong Xerces version. Now, don't ask me how
>>to fix that in eclipse, but if you can make ant use Cocoon's xerces you
>>should be fine.
> 
> 
> This is a very weird error. I am compiling and debugging Cocoon CVS with
> Eclipse 3.0 M7 and no problems reported.
> 
> I don't think the problem is releated to Xerces in ant 1.6.1:
> 
> Eclipse 3.0 M7 uses Ant 1.6.0 and XML4J 4.0.13 based on Xerces 2.0.0
> <website>http://www.alphaworks.ibm.com/tech/xml4j</website>
> Cocoon 2.1.5-dev (CVS) uses Ant 1.6.1 and Xerces 2.6.2
> 
> I will review the build system if there can be a potential problem.

I don't understand your argument. I'm almost sure it is an endorsed libs 
problem as almost everything related to XML and JDK 1.4 is a endorsed 
libs problem :-( I don't see how Eclipse (or the ant process started 
from inside Eclipse) should make an exception for this.

Joerg

Mime
View raw message