cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Unico Hommes <un...@hippo.nl>
Subject Re: [VOTE] - Entry level JSDK 1.4 in Cocoon 2.2
Date Mon, 01 Mar 2004 17:28:18 GMT
David Crossley wrote:

>Ugo Cei wrote:
>  
>
>>Antonio Gallardo wrote:
>>    
>>
>>>Do you agree with JSDK 1.4 as the lower Java version supported in Cocoon 2.2?
>>>
>>>Here is my +1
>>>      
>>>
>>-0.5
>>
>>Even though 1.4 is available for most platforms, and I've been using it 
>>exclusively for quite a long time, I still think there are many 
>>environments where people are forced to use 1.3 (not to mention 1.2) and 
>>upgrading wouldn't be an easy task.
>>
>>If, and when, we have something that absolutely requires 1.4 (say, a new 
>>caching system based on NIO, like Pier suggested), we might reconsider 
>>this requirement. Doing it now would just alienate many users without 
>>really buying us anything important.
>>
>>I suggest to repeat this vote when we have a proposed time frame for the 
>>release of 2.2.
>>    
>>
>
>This question should probably be asked on the users mail list.
>
>There are lots of government agencies that are way behind.
>Version 1.3 is their limit and maybe even 1.2 in some cases.
>
>  
>
I think that as a software product that is known for its innovative 
nature it is *very* important in the interest of Cocoon to refuse being 
impaired by the immobility of bureaucracratic organisations. We are 
having a small crisis on our hands ATM regarding our persistent store 
component and if I was reading Pier correctly he was willing to dedicate 
some time towards a solution to this problem.

One of the main attractions of the jdk 1.4 is its NIO package, and it's 
supposed to be a major improvement in Javas IO performance. With 1.4 
being available for - what more than two years? - and 1.5 already on the 
horizon it is IMHO the right time to upgrade.

+1 for 1.4

Unico

Mime
View raw message