cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: FlowScript in 2.1.5-dev has gone tango uniform
Date Tue, 02 Mar 2004 22:07:29 GMT
Hi Jeremy:

Are you updated your endorsed libs? Please don't get offended by the
obvious question, but I thought this problem is related to this issue. Can
you check this?

Best Regards,

Antonio Gallardo.

Jeremy Quinn dijo:
> Hi All
>
> I just upgraded my copy of Cocoon to today's CVS version.
>
> A (previously working) site that uses a lot of FlowScript has gone
> completely TU.
>
> I am getting a lot of this :
>
> org.apache.cocoon.ResourceNotFoundException: Function
> "javascript:album()" not found
>
> Where it worked before the update.
>
> But stranger still, while I was doing some testing, I got an error that
> said that a script that was not even referred to by the current
> pipeline, did not contain the function I was calling !!!!!!
>
> Do what ?!?
>
> Have there been some changes to the FlowScript infrastructure that
> could result in the wrong FlowScript file being used under certain
> circumstances?
>
> I have several flowscripts, used independently by different
> Sub-SiteMaps, that have the same function names. The first SiteMap I
> invoke, works (does not matter which one) all subsequent invocations of
> pipelines with similar (but different) FlowScripts fail.
>
>
> Any ideas anyone?
>
>
> regards Jeremy


Mime
View raw message