cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christoph Gaffga" <cgaf...@triplemind.com>
Subject Re: Entry level JSDK 1.4 in Cocoon 2.2
Date Thu, 04 Mar 2004 11:47:34 GMT
> Did you solve your problems with running ant using JDK? I proposed to
> run Ant with a JRE < 1.5 and use the 1.5 compiler explicitly in the
> <javac> task of Ant. Did you try this?

no, I haven't tried yet. I just started build with JAVA_HOME pointing to 1.5
and getting an error like:
Buildfile: build.xml
init-tasks:
Compiling 2 source files to /home/cgaffga/data/cocoon-2.1.4/tools/anttasks
javac: source release 1.4 requires target release 1.4
BUILD FAILED
/home/cgaffga/data/cocoon-2.1.4/tools/targets/init-build.xml:132: Compile
failed; see the compiler error output for details.


So I had a look at init-build.xml, but couldn't figure out what went wrong.
But for seems that it has something to do with changed  -target param in
javac.
http://stefanbodewig.blogger.de/20040112/


As soon as I have some time, I will try with JRE 1.4 nad javac from 1.5

regards
Christoph Gaffga
cgaffga@triplemind.com



----- Original Message ----- 
From: "Reinhard Pötz" <reinhard@apache.org>
Newsgroups: gmane.text.xml.cocoon.devel
Sent: Thursday, March 04, 2004 9:45 AM
Subject: Re: [VOTE] - Entry level JSDK 1.4 in Cocoon 2.2


> Christoph Gaffga wrote:
>
> >>The idea is to set JSDK 1.4 as the minimum supported JDK supported for
the
> >>next major release 2.2 of Cocoon. Currently we are supporting also 1.3
but
> >>seems like few people is using it.
> >>
> >>
> >
> >but what about the maximum support JDK? I tried to compile with 1.5beta,
but
> >it didn't work. So I compiled with 1.4 and let it run with 1.5. The gc
ist
> >much better with 1.5!
> >
> >
> Did you solve your problems with running ant using JDK? I proposed to
> run Ant with a JRE < 1.5 and use the 1.5 compiler explicitly in the
> <javac> task of Ant. Did you try this?
>
> -- 
> Reinhard
>
>


Mime
View raw message