cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: DO NOT REPLY [Bug 26753] - Persistent store or cache corruption?
Date Sun, 08 Feb 2004 17:59:22 GMT
Bertrand Delacretaz wrote:

> -----Original Message-----
> From: Bertrand Delacretaz [mailto:bdelacretaz@apache.org]
> Sent: Sunday, February 08, 2004 9:49 AM
> To: dev@cocoon.apache.org
> Subject: Re: DO NOT REPLY [Bug 26753] - Persistent store or cache
> corruption?
>
>
> Le Samedi, 7 fév 2004, à 23:44 Europe/Zurich, Geoff Howard a écrit :
>
> > bugzilla@apache.org wrote:
> >
> >  > http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26753
> >> Persistent store or cache corruption?
> >> ------- Additional Comments From cziegeler@apache.org  2004-02-07
> >> 18:34 -------
> >> Afaik, this is a known Jisp bug which should be fixed according to
> >> Scott with Jisp 3.0. We could try to switch to Jisp 3.0 after the
> >> release and see what happens.
> >
> > Are you saying after the release because Jisp 3.0 would require more
> > changes in the excalibur/cocoon code?  From what I read about this
> > bug, I'd say it's important enough to try to fix it before the release
> > if at all possible, no?
>
> Releasing with this bug worries me as well. In my tests I've seen
> either garbage or wrong pages (ie another page than the one I did
> request) being served, this is a serious problem.
>
> The Cocoon core is known to be very stable and reliable, we don't want
> to give a bad impression here IMHO.  I'd consider it a blocker and
> would vote against the release unless there is at least a workaround.
>
Now, in general I totally agree with you, but I fear that this bug is
in there for a long time, which means all 2.1.x releases have already
this bug (perhaps I'm wrong). Afaik, this bug happens only on some
environments and we never managed to exactly find out, what the
real problem is (perhaps a specific JDK version on a specific
OS, or a combination, don't know).
Anyways, I would say: if this bug is already in 2.1.3, we could
release 2.1.4 with it as well. We fixed a lot of other problems, so
at least 2.1.4 is not worse than 2.1.3.
I don't know the impact of switching to 3.0 of Jisp. It is a dot zero
release which could cause other problems. So, if we switch to
3.0 we need imho a longer testing period which would in my view delay
the 2.1.4 release.

WDYT?

Carsten


Mime
View raw message