cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Composable => Serviceable (was: [IMP] Code Freeze for 2.1.x)
Date Sat, 07 Feb 2004 16:07:03 GMT
On 07.02.2004 16:57, Carsten Ziegeler wrote:

> We are doing the "full move" with 2.2.
> 
> For 2.1.x we should prefer compatibility over "clean code", so we should
> only change Composable to Serviceable if we can assure that no user is
> affected by the change.

Ok, "assure" is only very difficult as almost every component could have 
been extended. I hope I have made a good decision on which components to 
move and which not. If anybody is aware of any problem related to this, 
please stand up and cry. I will remove it for that component.

The remaining components with a higher chance of being extended I will 
let untouched for 2.1.x. In 2.2 the component package is almost 
completely removed already.

Joerg

Mime
View raw message