cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: qdox block broken
Date Sun, 29 Feb 2004 05:15:16 GMT
Hi Bertrand:

I checked it. The problem seems again to be related to getJavaClass(String
className) method returnig "null" at line 778. Seems like another problem
with the source resolver URI:

At line 749-755 there is:

JavaClass jClass = null;
SourceResolver resolver = null;

try {
  resolver = (SourceResolver) manager.lookup(SourceResolver.ROLE);
  Source source = resolver.resolveURI("javadoc:" + className);
  if (source instanceof QDoxSource) {

The "if-condition" is "false" (not success) and the code inside the
if-block not run. This code use QDocSource to parse the javaclass.Because
the code is not called, then the getJavaClass() method return null. This
happen while resolving the java.util.Map class. After this happen we see
the error page.

AFAIK, this is not a problem of the new library, but a problem related to
resolver.resolveURI that does not return the right type (QDoxSource).

Is this correct?

I wonder if the code worked before the update. Can someone confirm if the
qdox block worked before with qdox.jar 1.2? (Cocoon 2.1.4 for example).

Best Regards,

Antonio Gallardo


Mime
View raw message