cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Larson <...@keow.org>
Subject Re: Cocoon/Jetty BindException
Date Thu, 05 Feb 2004 20:22:36 GMT
On Thu, Feb 05, 2004 at 09:02:01AM -0500, Geoff Howard wrote:
> Tim Larson wrote:
> >On Thu, Feb 05, 2004 at 09:46:02AM +0100, Reinhard Poetz wrote:
> >
> >>Are you sure that you have only started one Jetty instance which is
> >>bound to the same port? I've just tried to start Jetty twice and get the
> >>same error.
> >>
> >>Call netstat -a on command line to find out more about your bound ports.
> >
> >
> >Thanks for responding.  There is only one instance; I had already checked
> >this with netstat -a.  I am going to try another full "cvs up -d, build
> >clean, build" today just to make sure this is a current problem, and I
> >will also try excluding the xindice block just to see if it is involved.
> >I will let you know what happens.
> 
> What did you look for with netstat -a?  Check out the hsql port and 
> xindice port to see if one of them has remained running, or if you 
> happen to have another service running on one of their ports, etc.  The 
> port are IIRC configured in cocoon.xconf

I could not find the xindice port in cocoon.xconf, or anywhere else for
that matter, except via Google.  In any case, I disabled xindice and hsqldb
in cocoon.xconf, but the "already bound" behaviour remained.

If I use "cocoon servlet" to start Jetty and Cocoon, wait for it to
finish starting, hit "Control C", wait for it to shutdown, and then
start it back up again with "cocoon servlet" it works fine.
However, if I request a page from Cocoon while it is up (tried
separately with IE5 and with telnet), and then take cocoon down with
"Control C" and start it back up then I get the "already bound" error.
Waiting several minutes before starting it back up solves the problem,
but that is not nice for development.

I suppose I could hack setReuseAddress into Jetty, but could this
problem be indicating that Cocoon is not closing connections properly?

Testing with Windows telnet I send "GET / HTTP/1.0" and get back the
main page followed by "Connection to host lost.", which I think is what
I should get, so I am confused what is happening.

--Tim Larson

Mime
View raw message